Как запустить чисто приложении графический интерфейс через терминал?

Некоторые запуск GUI-приложений чисто через командную строку терминала, но некоторые нет, и они в терминале и ждать приложение, чтобы завершить. Даже тогда, некоторые не "выпустить" в командной строке.

Таинственный амперсанд & суффикса, кажется, чтобы вызвать терминал, чтобы поставить процесс на задний план (но я не уверен, что там происходит).

Есть ли способ, чтобы запустить приложение через терминал, так что нет "подождите" эффект, так же, как начало чего-то через АЛТ+Ф2?

Я бы хотел, чтобы в командной строке снова доступен сразу же, без чего-то еще в фоновом режиме и печати в терминале.

+952
Bjarne77 13 янв. 2019 г., 14:50:16
25 ответов

Вы, кажется, есть проблемы с подключением к запуска через SSH. Убедитесь, что у вас есть публичный SSH-ключ зарегистрирован на Launchpad, для которых у вас есть закрытый ключ доступен локально, и убедитесь, что на Launchpad знает о вашем логине (БЗР ЛП-логин <имя пользователя>).

Чтобы создать SSH ключ вы можете:

СШ-кейген

Затем вы можете легко загрузить ваш публичный ключ для SSH на Launchpad (обычно ~/.по SSH/id_dsa, который находится.паб или ~/.по SSH/id_rsa.паб).

Кроме того, так как вы только пытаетесь получить доступ к государственной власти (которые не требуют проверки подлинности) вы можете также просто сил БЗР использовать HTTP, выполнив БЗР конфиг --удалить launchpad_username.

+929
Empeebb 03 февр. '09 в 4:24

Я не в курсе. Создает дополнительные строки в меню загрузки вариант? В том случае, если вы выберите другую строку в меню загрузки вместо клавиши W или L, как предложено. Но я думаю, что у вас уже есть две линии в меню.

Есть опция, чтобы автоматически выбрать последний выбор, который вы сделали.

+876
whitemore 1 апр. 2011 г., 18:25:01

Я пытаюсь установить новая версия скайп (4.1) на линуксовые.

Я скачал скайп-Убунту-lucid_4.1.0.20-1_i386.деб пакет с официального сайта скайп.

Я удалил все установленные версии, включая файлы конфигурации.

Теперь когда я пытаюсь установить скачанный пакет, я получаю следующее ошибки:

Распаковка скайп:для i386 (от Skype-debian_4.1.0.20-1_i386.деб) ...
с dpkg: проблемы зависимостей предотвращает настройку скайпа:для i386:
 скайп:для i386 зависит от libqt4-сети (>= 4:4.8.0); однако:
 Версия libqt4-сеть:i386 на Система 4:4.7.4-0ubuntu8.2.
 скайп:для i386 зависит от libqtgui4 (>= 4:4.8.0); однако:
 Версия libqtgui4:i386 на Система 4:4.7.4-0ubuntu8.2.
 скайп:для i386 зависит от libqtwebkit4 (>= 2.1.0~2011week13); однако:
с dpkg: ошибка при обработке по Skype:для i386 (--установки):
 проблемы зависимостей - оставляем "не задано"
Обработка триггеры для desktop-файл-утилиты ...
Обработка триггеров для bamfdaemon ...
Восстановление /usr/доли/приложения/фумб.индекс...
Обработка триггеры для GNOME-меню ...
Ошибки возникли при обработке:
скайп:для i386

Теперь я думал: могу ли я установить недостающие зависимости вручную, но это у меня опять ошибки зависимостей. Кажется, что зависимости пакета не загружаются и не устанавливаются автоматически.

Есть ли команды для команды dpkg , так что недостающие зависимости устанавливаются автоматически?

+865
Thomas Mueller 20 янв. 2018 г., 19:07:57

Супер пользователь имеет приятный пошаговые инструкции о том, как решить эту проблему

Вот другой набор инструкция делать то же самое http://www.ubuntugeek.com/how-to-change-the-mysql-data-default-directory.html

Вот это перепостить. Пойти и проголосовать оригинальным, если вы можете на супер пользователя.

После некоторой общей суматохе о разрешениях я понял, что проблема не в том, что у меня не было моего разрешения и пути в порядке, но что то AppArmor препятствует MySQL от чтения и письма в новое место.

Это мое решение:

Первая остановка MySQL, поэтому ничего странного не происходит, пока ты возился:

$ судо остановить MySQL

Затем переместите все каталоги баз данных в новый дом:

$ судо МВ в /var/библиотека/MySQL в/<все папки> /новый сервер реж/

Не переместите файлы, они будут автоматически в MySQL, просто переместить папки (которые являются базы данных).

Потом вежливо попросить в AppArmor, чтобы позволить MySQL использовать новую папку:

$ судо ВИМ /и т. д./В AppArmor.д/УСР.переключатель.тузды

добавить строки:

/новый сервер, реж/ Р
/новый сервер реж/** rwk успешно,

Затем сообщить MySQL, что datadir не сдвинулся:

$ судо ВИМ файл /etc/mysql в/мой.КНФ 

измените строку:

переменной datadir=/ВАР/Либ/MySQL для

к:

переменной datadir=/мой-новый-дБ-ДМО/

Примечание: в зависимости от настроек базы данных может потребоваться изменить InnoDB в-сведения-дом-Дир и т. д. как хорошо.

Перезагрузите в AppArmor, чтобы прочитать новые параметры:

$ судо /етц/инит.Д/в AppArmor перезагрузить

И опять запустить MySQL с помощью новой переменной datadir:

$ судо запуска MySQL

Надеюсь, что это помогает!

+852
user135319 3 сент. 2013 г., 10:55:38

Откройте терминал и перейдите в папку, где файл находится. Затем введите:

Ш. <имя файла>.ш
+807
neizzhalyiigor 11 сент. 2016 г., 18:32:22

Проблема на самом деле в Windows, а не Linux. Microsoft написала своей системе, чтобы попытаться захватить компьютер в целом от любых других операционных системах. Несколько обновлений Windows (я предполагаю, что вы включили автоматические обновления для Windows?) попытается убить загрузчик GRUB.

Хотя есть способы программного обеспечения (например, переустановке Ubuntu), мое личное предложение для избежания этого постоянно нужно добавить второй внутренний жесткий диск к компьютеру. (Это гораздо лучше для стабильности системы в любом случае! Одного жесткого диска для каждой операционной системы, и одна "документов и носителей информации" жесткий диск, где вы храните свои файлы, фотографии, фильмы и т. д. Обычно это гарантирует, что если что-то ужасно умирает, вы не будете полностью потеряны, особенно, как и любой большой ошибки случаются, как правило, будет происходить на операционной системе жесткого диска.) Тогда можно полностью отказаться от жратвы и Windows переопределяет но только попав в ваши компьютеры ключевые БИОС меню "устройство загрузки" при загрузке и просто изменить какой диск вы используете.

+755
nictrix 26 окт. 2016 г., 12:10:42

urllib2 делает именно то, что он сказал и не автоматически распаковать содержимое потоков. К счастью, это не слишком сложно.

Кроме того, если вы всегда используете один и тот же сервер, вы можете пропустить проверку на кодировку gzip.

от импортных Ио BytesIO
импорт с помощью gzip

торрент = urllib2.urlоткрыть(torrentURL, таймаут=30)
буфер = BytesIO(торрент.читать())
ГЗ = gzip-сжатия.GzipFile(fileobj=буфера)
вывод = открыть('mytorrent.торрент', 'ВБ')
выход.писать(ГЗ.читать())

Я подкровать в Ио.BytesIO , чтобы сохранить эту совместим с Python 3.

+736
Raj Jetvana 19 авг. 2017 г., 16:48:39

Я не согласен с выводом @dv3500ea, в "ОК помощью", как это было неуместно. Даже по заявленной даты/времени .лзма файлы были известны полностью заменить .ХZ. Автор и утилиты публично заявил, пользователям следует переход к XZ-utils версии ≥ 5.00. Последние ЛЗМА-utils версии релиз был 2008-07-30, и прекращенная.

ЛЗМА utils являются устаревшее программное обеспечение для сжатия данных с высокой степенью сжатия. ЛЗМА утилиты больше не развивается, хотя критические ошибки могут быть исправлены как их устранение не требует серьезных изменений в код.

Пользователи в LZMA utils и должны двигаться к XZ utils версии. В XZ utils и поддерживать наследие .лзма формат, используемый ЛЗМА утилит, а также эмуляции командной строки в LZMA utils версии. Это должно сделать переход от LZMA utils к XZ utils и относительно легко.

Определяющим фактором может не быть компрессии, хотя по иронии судьбы именно в этом примере. "практические причины" само-собой разумеющимся, и значительным, оснований для применения в XZ-utils версии. Дополнительно .ХZ формат позволяет задавать алгоритмы сжатия и фильтры, поэтому .ХZ файлов можно использовать либо ЛЗМА или LZMA2. Во избежание создания новых .лзма файлы, они считаются устаревшим форматом.

Как еще держать ЛЗМА-utils и вокруг: нет. В XZ-utils и имеет поддержку наследия .лзма файлов. Она также имеет фантиков для скриптов еще с помощью LZMA-utils версии. Если все эти причины по-прежнему были недостаточными, Убунту за наследие лзма-utils с его репозитория.

+730
Walker in the City 12 дек. 2010 г., 21:38:01

Согласно указаниям по скайпу протоколирования и отладки, для отладки в Skype процесс:

  • Закрыть Skype
  • Создать каталог "журналы" в свой каталог данных скайп (~/.Скайп/)
  • Перезапустить Скайп
  • Файл журнала (skype_yyyy-ММ-ДД ччммсс) будет создан в ~/.Скайп/Журналы
  • Чтобы выключить входа, удалить папке "logs"

Вы можете подать отчет об ошибке в скайп трекера. Есть клиент Skype для Linux вариант в списке. Заполнить описание и прикрепить отладки и другие (если есть) файлы журналов Вы были хвостовых (хвост -Ф ~/SomeLogFile). И надеюсь, что вопрос решен в следующем обновлении. (-8

+726
bts 18 мая 2012 г., 20:31:09

Пожалуйста, см. посты #2 и #4 здесь: http://ubuntuforums.org/showthread.php?t=1800178&highlight=rt5370sta расположение файла изменилось здесь; см. RT8070 /RT3070 /RT3370 /RT5370 /RT5372 USB с: http://www.ralinktech.com/en/04_support/support.php?sn=501

Или можно обновить до 12,10, где это поддерживается по умолчанию с rt2800usb.

+672
The Obscure Question 11 мая 2015 г., 2:48:55

Ubuntu-это гораздо больше, стабильнее и безопаснее. Я полностью перешел на Ubuntu 3 года назад и я ни разу не пропустила окна еще с тех пор. Если вы привыкли с Ubuntu и Vista нестабильно на вашем ноутбуке, то вы должны удалить Vista и установить только Убунту. Даже если есть какая-то программ для Windows, которые вы хотите или должны использовать, вы можете легко установить Windows в виртуальную коробку и запустить, что софт есть. Таким образом, вы не случае необходимости переключаться между операционками.

+590
Simon Stead 30 дек. 2015 г., 2:20:54

Покуда вы практически "спрятать" телевизор живой хаб за ПЦ1 будет невозможно (без каких-либо ухищрений) на другие компьютеры, чтобы увидеть его.

Что касается IP-адреса: ТВ-концентратор использует подключение к ПЦ1 он должен иметь правильный IP-адрес для этой сети (через кроссовер). Так что оставьте эти адреса хорошо в одиночку.

+585
sashka1609 17 июн. 2012 г., 12:46:42

Вы можете следить за этой нитью.

Дайте нам знать, если он работал. Удачи.

+568
VLADDEM 31 мар. 2019 г., 9:51:49

У меня есть более одного раздела (4). Я должен удалить некоторые перегородки, чтобы поместиться в Ubuntu (ОС Windows 8)?

Мне очень нравится двойной загрузки Ubuntu 13.04 на Windows 8 на ноутбуке. Я хотел бы установить его на USB, а затем загрузить его и попробовать потом дать ОС отдельный раздел.

Это безопасно, чтобы иметь более чем четыре секции, а затем добавить пятую? Я не особенно обидчивый парень, поэтому условия laymens пожалуйста!

+463
LynetteG 22 окт. 2016 г., 19:32:34

Когда я иду через Мастер установки не находит драйвер для P513w в списке. Так я прошла через все 7 (вроде 1100), которые находятся в списке, но ни один из них не работает. Кто-нибудь есть идеи?

Тим

+447
Dussel Dorf 7 нояб. 2011 г., 16:05:24

Я запускаю Старкрафт через вино. Он отлично работает, но я не знаю, как добавить запись в список серверов. В Windows это добавлено через reg файл.

+439
Michael Darragh 1 июл. 2014 г., 13:41:32

Возможные Дубликаты:
Как я могу восстановить утерянную административные(корень) пароль?

Мне досталась машина с Ubuntu Desktop установлен. Это был пароль, и я не понимаю, что пароль может быть. Я не могу попасть в командную строку, чтобы использовать методы, которые я нашел онлайн. Неважно, сколько раз я нажимаю "Шифт" во время процесса загрузки она все равно проходит весь путь к рабочему столу входа в систему. Я никогда не видел жратвы. Я не уверен, какая версия у меня есть, но я думаю, может быть 9 или 10.

Спасибо

Даг


ОК, Глава II

Я 10.04.1, кстати.

Я попробовал, удерживая клавишу Shift и попал в меню загрузки. Мой был под названием ГНУ харч 1.98-1unbuntu7

Он имеет несколько перечисленных ядер, но никто не говорит...в Ubuntu, ядра. А у меня говорит (наряду с несколькими старыми версиями)

В Ubuntu, с Linux 2.6.32-24-generic и.

Я нажал " е " о том, что в любом случае и попадал на страницу, которая показывает:

recordfail
insmod ext2 в
установить параметр root = '(hd0,1)'
поиск ... нет-дискеты --ФС-идентификатор-набор (длинный идентификационный номер)
в Linux файл /boot/vmlinuz-2.6.32-24-родовой корень=идентификатор UUID (тот же длинный номер) РО тихий всплеск
файл initrd в /boot/initrd, который.ИМГ-2.6.32-24-универсальный




Когда я пытаюсь addd в режиме RW init=/Бен/Баш и нажмите Esc, затем еще раз он ушел. Если я пытаюсь перезагрузить (сочетание клавиш Ctrl-х) после ввода выше он переходит на рабочий стол заблокирован.

Я также попробовал "живой" CD (у меня 8.04.1 на CD). Что работал, до тех пор, пока я пытался установить существующим HD. Он сказал, что это был ext4 и не совместимы. Я использовал для управления разделами и она показала, что раздел с ext3. {плечами}

Я загрузился в режиме восстановления и можно добраться до корня командной строки. Он показывает имя машины, но я не уверен, где я должен идти оттуда, хотя найти информацию пользователей. Может, КД на /dev/СКБ?? Я знаю, что корень-это нет-нет да и я не хочу, чтобы разбить его .. . Я просто хочу сделать и не надо переустанавливать!

Спасибо

Даг

+420
DAlina 4 мар. 2014 г., 22:59:03

Я выполните следующие команды:

судо программой groupadd -Р testgroupбыл
судо команды useradd -г testgroupбыл -м -р testuser

Заметьте вариант, который, по словам человека страницы:


Создать системную учетную запись.

Если у меня есть учетная запись Пользователя с привилегиями root, потом я запускаю:

судо -у testuser кота на /dev/вход/mouse0

Тем не менее, я получаю:

кот: на /dev/вход/mouse0: разрешение отклонено

Под управлением той же команды, как корень обеспечивает ожидаемый выход (искаженный выход из драйвера мыши).

Как я могу создать пользователя с правами root?

+390
jkabrg 28 янв. 2011 г., 18:00:21

Как об установке только необходимые шрифты от MS шрифтов я.е загружать шрифты и настройки браузеров на свой приоритет шрифтов ?

+324
vrwim 26 мар. 2018 г., 13:17:38

Я получил некоторую помощь на другом форуме: учитывая тот факт, что мы не волнует, если наши серверы сохраняют тот же DHCP арендует, я пойду с новой, пустые файлы.

+311
Alessandro Ruffolo 25 февр. 2013 г., 19:19:10

У меня была похожая проблема где-то у меня было два противоречивых таблиц разделов. Я использовал LiveCD и затем использовать утилиту под названием fixparts, которые сортировали проблему. Подробности здесь: http://www.rodsbooks.com/fixparts/.

+172
Philippe Santana 25 авг. 2014 г., 18:23:25

Я установил Ubuntu 12.04 LTS на три настольных систем Intel. Все три шт используете ту же версию ядра (3.2.0-29-generic и физических). Но у меня есть проблема, когда я скомпилировать и построить свой исполняемый файл на одном ПК, он не будет работать на другом ПК, и отображается сообщение об ошибке "команда не найдена". Однако, если один и тот же код перестраивается на другой ПК, он работает успешно. Как я могу сделать мой исполняемый построен на одном ПК запуск на другом ПК с той же Убунту 12.04 с ядром Линукс?

+112
Daniel Falbel 26 дек. 2016 г., 4:18:34

Вы можете попробовать установить совместимость с ACPI , а потом звонит с ACPI-V и получить информация об аккумуляторах и температуры для вашей машины.

судо apt-получить установку с ACPI
с ACPI-в
+92
Juddymarry01 1 дек. 2018 г., 0:50:24

Я думаю, что у меня была такая же проблема, и вот как я это исправил.

В файле/etc/интерфейсом dconf/профиль, там были две небольшие текстовые файлы, “ГДМ” и “пользователей”. “ГДМ” выглядела так:

пользователь-БД пользователей
системы БД:ГДМ

в то время как “пользователь” выглядела так:

пользователь
ГДМ

Так, я изменил “user”, чтобы выглядеть в точности как “ГДМ” (судо нано /etc/интерфейсом dconf/профиль/пользователь будет работать), перезагрузка, и вдруг, все настройки снова работали. Поэтому, проверьте, чтобы увидеть, если у вас есть файлы “ГДМ” и “пользователь”, и посмотреть, если они похожи на то, что я имел раньше. Если это так, попробуйте делать то, что я сделал и посмотреть, если это работает. Удачи!

+58
LongJeongS 28 февр. 2010 г., 7:17:08

Возможные Дубликаты:
Как я могу исправить вспышки проблемы?

Я не могу получить Adobe флеш работает в Firefox или Chrome. Я пробовал Флэш-помощь плагин для Firefox, но он не сделал никакой разницы. Насколько я могу судить, вспышка устанавливается без ошибок и Firefox думает, что он может запустить Flash но (например) на YouTube просто показывает пустой квадрат, где должен быть я. Отчеты хром "отсутствует плагин".

о:плагины в Firefox сообщает:

Шоквейв Флеш

Файла: libflashplayer.так
Версия: 
Шоквейв флеш 11.2 r202

Тип MIME описание суффиксов применение/х-ударно-вспышка Шоквейв флеш SWF приложения/futuresplash FutureSplash плеер шлицов

+38
user3131252 1 янв. 2011 г., 7:13:57

Показать вопросы с тегом